Monday, 18 July 2016

Internet Routing Protocols : OSPF : Open Shortest Path First

Or, Routing Protocols : OSPF
Or, What is OSPF and How to Configure OSPF?

Descriptions:
OSPF stand for Open Shortest Path First. routers connect the network using internet protocol and OSPF is a routing protocol used to find the best route for packets as they pass through a set of connected networks.

Lab 1.1


How to Configure OSPF ?

Descriptions: OSPF Configuration syntax as follows
Router(config)#router ospf <OSPF Process number>
Router(config-router)#network <Network ID> <Wild Card Mask> area <Area number>
OSPF Process number: Is just a number local to the router only. This value does not ensure be the same on all router within the area. Though, it is better to keep this as same for all routers inside an area for better administration.
Network ID: Is the directly connected network address.
Wildcard mask: Is the inverse of Subnet mask
Area number : Logical group of OSPF network.
Cisco Packet Tracer OSPF Configuration Example : Please see the OSPF Network Topology Using Lab 1.1














Cisco OSPF Network Command for Router 1 
R1>enable
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z
R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#network 20.0.0.0 0.255.255.255 area 0
R1(config-router)#exit
R1#
%SYS-5-CONFIG_I: configured from console by console
R1#














Cisco OSPF Network Command for Router 2 
R2>enable
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z
R2(config)#router ospf 1
R2(config-router)#network 10.0.0.0 0.255.255.255 area 0
R2(config-router)#network 30.0.0.0 0.255.255.255 area 0
R2(config-router)#exit
R2#
%SYS-5-CONFIG_I: configured from console by console
R2#
Cisco OSPF Network Command for Router 3
R3>enable
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z
R3(config)#router ospf 1
R3(config-router)#network 10.0.0.0 0.255.255.255 area 0
R3(config-router)#network 40.0.0.0 0.255.255.255 area 0
R3(config-router)#exit
R3#
%SYS-5-CONFIG_I: configured from console by console
R3#
Cisco OSPF Network Command for Router 4
R4>enable
R4#conf t
Enter configuration commands, one per line. End with CNTL/Z
R4(config)#router ospf 1
R4(config-router)#network 10.0.0.0 0.255.255.255 area 0
R4(config-router)#network 50.0.0.0 0.255.255.255 area 0
R4(config-router)#exit
R3#
%SYS-5-CONFIG_I: configured from console by console
R4#

OSPF Verification and Testing Commands

#Show ip ospf















#Show ospf interface <interfaces>

No comments:

Post a Comment